Ubuntu: What should I do as apt-get wants to remove grub-efi-amd64-signed



Question:

I'm on 15.04 and latest upgrade shows grub-efi-amd64-signed as "to be removed" (along with upgrading grub-common, grub-efi-amd64, grub-efi-amd64-bin and grub2-common)

I'm using EFI secure boot, so I think removing grub-efi-amd64-signed might brake my system.

Does anyone have an advice on that ?


Solution:1

I did the update yesterday on 14.04, and 15.04, and it went OK. What I think it does, it removes an older version, and installs a newer one. Both systems have been rebooted, and they both work fine.


Solution:2

This is a a kown issue: https://bugs.launchpad.net/ubuntu/+source/grub2-signed/+bug/1469995

Afaik it seems related to a dependency problem as updating "grub-efi-amd64" package suggest to remove "grub-efi-amd64-signed" as the last one depends on previous version of the first one.

You should not update now and wait one or two weeks and see if the issue is fixed.


Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »