Ubuntu: Vim refuses to start with “error while loading shared libraries: libperl.so.5.14” after upgrade to Ubuntu 14.04



Question:

After I upgraded to Ubuntu 14.04 vim refuses to start, showing the following error:

vim: error while loading shared libraries: libperl.so.5.14: cannot open shared object file: No such file or directory  

Now, I reinstalled perl, I checked /usr/lib for libperl.so.5.14 file, there are three: libperl.so.5.14, libperl.so.5.14.2 and libperl.so. Yet I still get this error. Why doesn't it see perl?


Solution:1

I had Vim installed manually from sources. For that reason, after the Ubuntu upgrade, some dependencies were broken. Solved by compiling and installing vim from source.


Solution:2

Just create a shortcut:

ln -s /usr/lib/x86_64-linux-gnu/libperl.so.5.20 /usr/lib/x86_64-linux-gnu/libperl.so.5.14  

 


Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »