Ubuntu: Upgrade YAZ to YAZ 5



Question:

Still a beginner, I don't know who I can ask. Problem: I try to use MarcEdit 6 (marcedit.reeset.net/). If I use its tool "Z39.50/SRU Client" to search for any book in any offered library-database it doesn't work and I get the message

  "Exception Information: Message: yaz4_64.dll    Source: Zoom.Net.YazSharp    Stack Trace: [...very long text...]"  

MarcEdit 6 needs YAZ 5 (indexdata.com/yaz). I installed "yaz 4.2.30-2.1build1" which is the only version offered in Ubuntu Software Center - neither is there a version 5 nor any possibility to upgrade. Without knowing what I was doing I also did what is recommanded here: http://ftp.indexdata.dk/pub/yaz/ubuntu/README but I'm not sure if I did everything right and if I didn't, where I made a mistake. Maybe somebody can help me with this very specific question.

In the linux_install.txt file of MarcEdit 6 there is recommanded: "d) Yaz.Sharp.dll.config -- ensure that the dllmap points to the correct version of the shared libyaz object." I have no idea what this means.

During the installation of MarcEdit 6 I did nothing exceptional (I unziped the downloaded file, installed "mono" and executed MarcEditor via the terminal). During the installation of YAZ I first manipulated my sources.list file as recommanded in the above README-link and finally just got YAZ via the Software Center).

UPDATE: I installed libyaz 5 ( sudo apt-get install libyaz5-dev ) and it's still the same problem when searching with the Z39.50 client.

I now also changed Yaz.Sharp.dll.config to version 5 (instead of before: 'dll="yaz3.dll"'):

<?xml version="1.0" encoding="utf-8" ?> <configuration> <dllmap dll="yaz5.dll" target="libyaz.so" /> </configuration>


Solution:1

I don't know if you will see this now, but the config you want to use is:

<?xml version="1.0" encoding="utf-8" ?>    <configuration>      <dllmap dll="yaz4_64.dll" target="libyaz.so.5" />  </configuration>  

This works for me.


Solution:2

It works, the developer told me to change in the Zoom.Net.YazSharp.dll.config file the following:

dll="yaz4_64.dll" target="libyaz.so"

But the following problem occured and the developer has no solution (he wrote: "that’s not a file referenced in MarcEdit")

Exception Information: Message: winhttp.dll Source: mebatch

This can be deleted if the topic is wrong here (it was just my stupidity which caused the problem).


Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »