Ubuntu: Unity broken, can't install due to unmet dependencies



Question:

Error Message: unmet dependencies libunity-core-6.09-9 (=7.2.2+14.04.20140714-0ununtu1) but 7.2.4+14.04.20141217-0ubuntu1 is to be installed

Removed compiz as directed by one of the answers earlier and it broke unity.

I don't have frames around firefox or any other app I can load from my desktop and I can only load apps that are on my desktop.

I tried sudo apt-get install unity and get an unmet dependencies error. The first time it listed about 12 or more items which i manually installed.

Now I only get this message.


I don't have unity back yet, but I was able to load Lubuntu-desktop, xubuntu-desktop and gnome. So at least I can get around now. However, gnome core has the same problem as unity.

I am still looking for an answer.

Thank you


Solution:1

run this commands

sudo apt-get clean      sudo apt-get -f install  

Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »