Ubuntu: Unable to run 'sudo apt-get dist-upgrade' due to authentication issues (Plesk repository)



Question:

I've just attempted to run sudo apt-get dist-upgrade on my Ubuntu box, but am getting the following error... WARNING: The following packages cannot be authenticated! librdbmspp php5-ioncube-loader sw-libboost-date-time1.49.0 sw-libboost-system1.49.0 sw-libboost-filesystem1.49.0 sw-libboost-program-options1.49.0 sw-libboost-regex1.49.0 sw-libboost-serialization1.49.0 sw-libpoco

I've tried running... $ sudo apt-key update $ sudo apt-get update ... as found in this question, but I'm still getting the error.

Can anyone help, please?

Update on 5th June

Repos currently in /etc/apt/sources.list:

deb http://gb.archive.ubuntu.com/ubuntu/ precise main restricted universe multiverse  deb http://gb.archive.ubuntu.com/ubuntu/ precise-updates main restricted universe multiverse  deb http://gb.archive.ubuntu.com/ubuntu precise-security main restricted universe multiverse  deb http://archive.canonical.com/ubuntu precise partner  deb-src http://archive.canonical.com/ubuntu precise partner  deb http://security.ubuntu.com/ubuntu precise-security main restricted universe multiverse  deb-src http://security.ubuntu.com/ubuntu precise-security main restricted universe multiverse  deb http://autoinstall.plesk.com/ubuntu/PSA_11.5.30 precise all  deb http://autoinstall.plesk.com/debian/SITEBUILDER_11.5.10 all all  deb http://autoinstall.plesk.com/debian/BILLING_11.5.30 all all  

apt-get:

Reading package lists...  Building dependency tree...  Reading state information...  The following NEW packages will be installed:    linux-headers-3.2.0-63 linux-headers-3.2.0-63-generic    linux-image-3.2.0-63-generic  The following packages will be upgraded:    iproute libgnutls-dev libgnutls-openssl27 libgnutls26 libgnutls26:i386    libgnutlsxx27 librdbmspp libssl-dev libssl-doc libssl1.0.0 libssl1.0.0:i386    linux-generic linux-headers-generic linux-image-generic openssl    php5-ioncube-loader sw-libboost-date-time1.49.0 sw-libboost-filesystem1.49.0    sw-libboost-program-options1.49.0 sw-libboost-regex1.49.0    sw-libboost-serialization1.49.0 sw-libboost-system1.49.0 sw-libpoco  23 upgraded, 3 newly installed, 0 to remove and 0 not upgraded.  Need to get 63.2 MB of archives.  After this operation, 217 MB of additional disk space will be used.  Do you want to continue [Y/n]? WARNING: The following packages cannot be authenticated!    librdbmspp php5-ioncube-loader sw-libboost-date-time1.49.0    sw-libboost-system1.49.0 sw-libboost-filesystem1.49.0    sw-libboost-program-options1.49.0 sw-libboost-regex1.49.0    sw-libboost-serialization1.49.0 sw-libpoco  Install these packages without verification [y/N]?  

apt-cache policy librdbmspp:

# apt-cache policy librdbmspp  librdbmspp:    Installed: 2.0-735641.13060715    Candidate: 2.0-735641.13073116    Version table:       2.0-735641.13073116 0          500 http://autoinstall.plesk.com/ubuntu/PSA_11.5.30/ precise/all amd64 Packages   *** 2.0-735641.13060715 0          100 /var/lib/dpkg/status  


Solution:1

# apt-cache policy librdbmspp  librdbmspp:    Installed: 2.0-735641.13060715    Candidate: 2.0-735641.13073116    Version table:       2.0-735641.13073116 0          500 http://autoinstall.plesk.com/ubuntu/PSA_11.5.30/ precise/all amd64 Packages   *** 2.0-735641.13060715 0          100 /var/lib/dpkg/status  

The output shows that package comes from Plesk. I would bet the rest of the ones that are unauthenticated do too. So I wouldn't worry about it, it is Plesk's problem, just say "y" to "Install these packages without verification [y/N]?" and it will do the upgrade.


Solution:2

http://forum.parallels.com/showthread.php?297194-Cant-update-11-5-30-on-Ubuntu-bind9-fail! shows that this issue can be caused by AppArmor not being disabled.

From http://kb.parallels.com/112903:

Symptoms

AppArmor is a security tool that uses name-based mandatory access controls to restrict or confine the system access of “at risk” applications. AppArmor is not supported by Parallels Plesk Panel. Sometimes AppArmor can interfere with Plesk installation or functionality.

Resolution

Disable AppArmor using the following commands:

/etc/init.d/apparmor stop  /etc/init.d/apparmor teardown  update-rc.d -f apparmor remove  

Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »