Ubuntu: Unable to install Skype on 64bit Ubuntu [duplicate]



Question:

This question already has an answer here:

Note: The legacy Skype for Linux application (v4.*) is now discontinued and was removed from Canonical’s partner repositories, so this question and its answers are obsolete. Please refer to a newer answer of our canonical Skype installation question.


I am receiving the following message while I am trying to install Skype:

nidhin@ubuntu:~$ sudo apt-get update  nidhin@ubuntu:~$ sudo apt-get install skype  Reading package lists... Done  Building dependency tree         Reading state information... Done  Some packages could not be installed. This may mean that you have  requested an impossible situation or if you are using the unstable  distribution that some required packages have not yet been created  or been moved out of Incoming.  The following information may help to resolve the situation:    The following packages have unmet dependencies:   skype : Depends: skype-bin but it is not installable  E: Unable to correct problems, you have held broken packages  

How can I fix this?


Solution:1

12.10 and newer

I had that same issue and what helped was to enable the 32-bit architecture by doing this:

sudo dpkg --add-architecture i386  sudo apt-get update  

then I was able to install skype via the Canonical Partner Repository:

sudo add-apt-repository "deb http://archive.canonical.com/ $(lsb_release -sc) partner"  sudo apt-get update && sudo apt-get install skype  


Solution:2

First of all you have to enable i386 architecture before running the below commands on your Ubuntu 64 bit system.

sudo dpkg --add-architecture i386  

Then run the below commands on terminal to install skype.

Ubuntu 13.10

sudo sh -c "echo 'deb http://archive.canonical.com/ saucy partner' >> /etc/apt/sources.list.d/canonical_partner.list"  sudo apt-get update  sudo apt-get install skype  

Ubuntu 14.04

sudo sh -c "echo 'deb http://archive.canonical.com/ trusty partner' >> /etc/apt/sources.list.d/canonical_partner.list"  sudo apt-get update  sudo apt-get install skype  


Solution:3

I suggest to remove skype-bin first completely and install Skype as follows.

Run following commands in Terminal

sudo apt-get remove skype skype-bin    sudo apt-get install libxss1      wget http://www.skype.com/go/getskype-linux-ubuntu-64/skype-ubuntu-precise_4.1.0.20-1_amd64.deb    sudo dpkg -i skype-ubuntu*.deb  


Solution:4

skype is not from ubuntu.it is a third party software supported by canonical foundation so edit your source.list using

$sudo gedit /etc/apt/source.list  

then add the following link into your source list

deb http://archive.canonical.com/ubuntu $(lsb_release -sc) partner  deb-src http://archive.canonical.com/ubuntu $(lsb_release -sc) partner  

$(lsb_release -sc) replace with your ubuntu name. Save it. Then update your repository using

$sudo apt-get update  

now run the following command to install skype

$sudo apt-get install skype  

this will install skype and skype.bin.


Solution:5

 12.10 and above and in particular 17.04:

https://www.skype.com/en/download-skype/skype-for-computer/

Download the deb package

If it isn't installed already install gdebi :

sudo apt update && sudo apt upgrade  sudo apt install gdebi  

then cd to the Downloads directory and run gdebi for the downloaded deb:

sudo gdebi â€"n skypeforlinux-64.deb  

(Or for an approach that doesn't even require installation of any extra software) :

sudo dpkg -i skypeforlinux-64.deb  

you may instead just right click on the downloaded file go into properties and set the default program to open this sort of file to gdebi (which is recommended in the meantime in 17.04) and then simply double click the file and when gdebi opens and finishes loading the file click install (you will be prompted for your password)


Solution:6

Try these commands:

sudo apt-get install libxss1   cd /tmp   wget http://www.skype.com/go/getskype-linux-ubuntu-64/skype-ubuntu-precise_4.1.0.20-1_amd64.deb  sudo dpkg -i skype-ubuntu*.deb

Source: http://www.tecmint.com/install-skype-4-1-in-ubuntu-xubuntu-linux-mint/


Solution:7

  1. download skype package from here
  2. install it with double-click
  3. open nautilus in /usr/share/applications/
  4. edit skype.desktop (fix for sound issue) and replace line:
    Exec= skype %U with Exec=env PULSE_LATENCY_MSEC=30 skype %U

  5. drag skype.desktop and drop on unity bar (this will make opening same skype instance after closing window)

Full code for the .desktop file can be found at: skype.desktop


Solution:8

This is common problem in 64 bits for installing Skype

First a downgrade is required and done with the following: create the 'preferences' file:

sudo vi /etc/apt/preferences  

and insert the following lines:

Package: *         Pin: release a=precise*  Pin-Priority: 2012  

Pin-Priority must be greater than 1000.

Then you may downgrade the offending applications with:

sudo apt-get dist-upgrade    Then you may install packages that complained about dependencies, like  sudo apt-get install ia32-libs-multiarch, or sudo apt-get install ia32-libs.  

Finally, you should remove the file you just created:

sudo rm /etc/apt/preferences  

Now download Skype From Official website(skype.com ) for multi architecture

then open the downloded package from software center then you should able to install skype


Solution:9

While other answers here provide the correct way to install skype, you might still get the same error (I did).

Running aptitude install skype might be more useful in finding what's causing the problem.

One possible cause is a system upgraded from 14.04 to 16.04.
Some packages from ubuntu 14.04 have version numbers that when compared to those in 16.04 are considered "higher". E.g.:

  • ubuntu 14.04: libdrm2 2.4.67-1ubuntu0.14.04.1
  • ubuntu 16.04: libdrm2 2.4.67-1

When upgrading from 14.04 to 16.04 these packages are not upgraded (and won't be upgraded later either) because ubuntu thinks, for example, that 2.4.67-1ubuntu0.14.04.1 is greater than 2.4.67-1.

This causes problems when trying to install their i386 counterpart needed by skype because the i386 version wouldn't match the amd64 one already installed (which where leftovers from 14.04).

The same problem applies to libdrm-intel1, libdrm-radeon1, libdrm-nouveau2, libdrm-amdgpu1, libdrm-dev, libuv1. This list is not exhaustive.

This can be solved by creating a file (e.g. /tmp/pin.txt) containing:

Package: *  Pin: release n=*  Pin-Priority: 1001  

and running:

sudo apt-get -o Dir::Etc::Preferences=/tmp/pin.txt dist-upgrade  

Warning: This will install the version available in the repositories for ALL packages. Be careful if you have installed any packages from somewhere else (just make sure apt-get is not trying to downgrade anything when prompted for confirmation).


Solution:10

Install Synaptic if you don't have it, Open it, then go to Edit > Fix Broken Packages. After that try to install Skype.


Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »