Ubuntu: Trouble installing sleuthkit package



Question:

BUILD FAILED  /home/ABC/Downloads/sleuthkit-4.1.3/bindings/java/build.xml:119: The following error occurred while executing this line:  /home/ABC/Downloads/sleuthkit-4.1.3/bindings/java/build.xml:98: impossible to resolve dependencies:      resolve failed - see output for details    Total time: 40 seconds  make[2]: *** [all-local] Error 1  make[2]: Leaving directory `/home/ABC/Downloads/sleuthkit-4.1.3/bindings/java'  make[1]: *** [all-recursive] Error 1  make[1]: Leaving directory `/home/ABC/Downloads/sleuthkit-4.1.3/bindings/java'  make: *** [all-recursive] Error 1  root@ubuntu:/home/ABC/Downloads/sleuthkit-4.1.3#  


Solution:1

I think you are experiencing the same problem as described here which says there is some problem in the bindings/java/ivysettings.xml in locating the repositories for sqlite-jdbc-3.8.0-SNAPSHOT.jar.

Currently it looks in http://oss.sonatype.org/content/repositories/snapshots/org/xerial/sqlite-jdbc/3.8.0-SNAPSHOT/sqlite-jdbc-3.8.0-SNAPSHOT.jar

but the file Ivy wants is actually at

https://oss.sonatype.org/content/repositories/snapshots/org/xerial/sqlite-jdbc/3.8.0-SNAPSHOT/sqlite-jdbc-3.8.0-20130827.035027-1.jar


Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »