Ubuntu: relocation error [closed]



Question:

In my application I need to use these libraries.But I get this error.I am so new at linux and these issues so I don't understand anything.Do you have any idea about this problem?

relocation error: /lib/libomi.so: symbol backtrace, version GLIBC_2.4 not defined in file libc.so.6 with link time reference


Solution:1

This message mean you used newly GLIBC libraries for your application. Looks like it actually was written on quite old GLIBC libraries. You should know GLIBC version used for writting this application and try to copy them to app folder or link with application in other way.

UPDATE:

One of good mail threads for this problem

https://sourceware.org/ml/libc-help/2013-08/msg00038.html


Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »