Ubuntu: Problems when trying to upgrade from 10.04 to 12.04 [duplicate]



Question:

This question already has an answer here:

When I was trying to upgrade my server from ubuntu 10.04 to 12.04 I was facing problems with some packages. It was saying,

sudo apt-get dist-upgrade  Reading package lists... Done  Building dependency tree  Reading state information... Done    You might want to run `apt-get -f install' to correct these.      The following packages have unmet dependencies:        gcc-4.4: Depends: gcc-4.4-base (= 4.4.7-1ubuntu2) but 4.4.3-4ubuntu5.1 is installed                 Depends: cpp-4.4 (= 4.4.7-1ubuntu2) but 4.4.3-4ubuntu5.1 is installed                 Depends: binutils (>= 2.20.1-15~) but 2.20.1-3ubuntu7.1 is installed                 Depends: libgcc1 (>= 1:4.4.7-1ubuntu2) but 1:4.4.3-4ubuntu5.1 is installed                 Recommends: libc6-dev (>= 2.13-0ubuntu6) but it is not installed        libnih-dbus1: Depends: libnih1 (= 1.0.3-4ubuntu9.1) but 1.0.1-1 is installed        libnih1: Depends: libc6 (< 2.12) but 2.15-0ubuntu10.5 is installed      E: Unmet dependencies. Try using -f.  


Solution:1

try first

sudo apt-get update -f

or

sudo apt-get update --fix-missing

then

sudo apt-get upgrade

then

sudo apt-get dist-upgrade

hope it will work for you , if not check you broken repo's (package's)


Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »