Ubuntu: Not able to install CURL on Ubuntu 12.04 [duplicate]



Question:

This question already has an answer here:

When I am trying to install the following error is coming

sudo apt-get install php5-curl  Reading package lists... Done  Building dependency tree         Reading state information... Done  You might want to run 'apt-get -f install' to correct these:  The following packages have unmet dependencies:   gedit : Breaks: gedit-plugins (< 2.91) but 2.30.0-0ubuntu1 is to be installed   php5-curl : Depends: php5-common (= 5.3.10-1ubuntu3.11) but 5.3.10-1ubuntu3.10 is to be installed  E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).  

Can anyone please highlight the issue and give some solution?


Solution:1

For CURL to work, it depends on some other packages.

The following packages have unmet dependencies: gedit : Breaks: gedit-plugins (< 2.91) but 2.30.0-0ubuntu1 is to be installed php5-curl : Depends: php5-common (= 5.3.10-1ubuntu3.11) but 5.3.10-1ubuntu3.10 is to be installed E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

This explains what all dependcies are not installed.

It is explained in the error itself apt-get -f install may solve your problem.

If this is not helping, You could try and install the dependencies one after one by downloading and compiling them, or install them directly using terminal.


Solution:2

Finally, I found the solution:

sudo dpkg --force-depends --purge gedit

sudo dpkg --force-depends --purge gedit

Followed by a quick

apt-get -f install

sudo dpkg --force-depends --purge gedit

sudo service apache2 restart

fixed it all.


Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »