Ubuntu: no sound in Ubuntu 14.04 x64



Question:

After every "suspend-wake'up" my computer have no sound. I must "renew" sound in these two steps:

  1. System settings>sound>input device, I shall microphone probe.
  2. System settings>sound>test sound.

Then sound in my computer working properly.


Solution:1

There is a bug that seems to relate to this issue and it seems related to running apps incompatible with pulseaudio 4.0. On my system if a PA compatible app is run last before the suspend, the bug is much less likely to occur. An answer to a similar question suggests killing pulseaudio (it restarts automatically). Creating an executable script "00custom" in /etc/pm/sleep.d that plays a sound and resets pulseaudio before suspending completely fixed the problem on my system. You need a Snoring.wav file in your Downloads folder for example this.

#!/bin/bash    # custom suspend resume stuff  #  # 1) play a suspend sound and reset pulseaudio to workaround Bug #1355025  #    DBUS_USERNAME=$(grep -z "USER" /proc/$(pidof gnome-session)/environ | cut -d= -f2-)  export XDG_RUNTIME_DIR=/run/user/$(/usr/bin/id -u $DBUS_USERNAME)  export HOME=/home/$DBUS_USERNAME    case "$1" in          hibernate|suspend)                    # play a suspend sound and reset pulseaudio                  /usr/bin/sudo -E -u $DBUS_USERNAME /bin/bash -c "/usr/bin/aplay /home/$DBUS_USERNAME/Downloads/Snoring.wav"                  /usr/bin/sudo -E -u $DBUS_USERNAME /bin/bash -c "/usr/bin/pulseaudio -k"                    ;;          *) exit                  ;;  esac  

Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »