Ubuntu: iPython frontend and kernel versions are incompatible



Question:

I have just upgrade my OS from 14.10 to 15.04. Spyder(Python 3.4) with iPython was working perfectly in 14.10. However, after the upgrade, iPython console failed to start up.

My python version I am working on is 3.4. I am working in a virtual environment with virtualenv and virtualenvwrapper installed.

Would appreciate if you all could advise me on what I could possible do to resolve this issue. Do let me know if need further details on this.

Meanwhile, the following might facilitate the troubleshooting process and I hope it would help, nonetheless.

Spyder Internal Console    This console is used to report application  internal errors and to inspect Spyder  internals with the following commands:    spy.app, spy.window, dir(spy)    Please don't use it to run your code    >>> Traceback (most recent call last):    File "/usr/lib/python3/dist-packages/spyderlib/plugins/ipythonconsole.py", line 790, in run_script_in_current_client      self.execute_python_code(line)    File "/usr/lib/python3/dist-packages/spyderlib/plugins/ipythonconsole.py", line 803, in execute_python_code      client.shellwidget.execute(to_text_string(lines))    File "/usr/lib/python3/dist-packages/IPython/qt/console/history_console_widget.py", line 46, in execute      source, hidden, interactive)    File "/usr/lib/python3/dist-packages/IPython/qt/console/console_widget.py", line 655, in execute      self._execute(source, hidden)    File "/usr/lib/python3/dist-packages/IPython/qt/console/frontend_widget.py", line 243, in _execute      msg_id = self.kernel_client.execute(source, hidden)  AttributeError: 'NoneType' object has no attribute 'execute'  

Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »