Ubuntu: Inkscape PPA not installing updates? [closed]



Question:

I have inkscape 0.48 installed and I'm trying to install inkscape 0.91 on the site they provide me with these commands

sudo add-apt-repository ppa:inkscape.dev/stable  sudo apt-get update  sudo apt-get install inkscape  

When I enter the 1st line of commands it comes up with this

You are about to add the following PPA to your system:   The Inkscape Stable PPA is intended to provide the current supported release of Inkscape.   More info: https://launchpad.net/~inkscape.dev/+archive/ubuntu/stable  Press [ENTER] to continue or ctrl-c to cancel adding it    Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --secret-keyring /tmp/tmp.Pph6xzLEzv --trustdb-name /etc/apt//trustdb.gpg --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyring /etc/apt/trusted.gpg.d//debian-archive-jessie-automatic.gpg --keyring /etc/apt/trusted.gpg.d//debian-archive-jessie-security-automatic.gpg --keyring /etc/apt/trusted.gpg.d//debian-archive-jessie-stable.gpg --keyring /etc/apt/trusted.gpg.d//debian-archive-squeeze-automatic.gpg --keyring /etc/apt/trusted.gpg.d//debian-archive-squeeze-stable.gpg --keyring /etc/apt/trusted.gpg.d//debian-archive-wheezy-automatic.gpg --keyring /etc/apt/trusted.gpg.d//debian-archive-wheezy-stable.gpg --keyserver hkp://keyserver.ubuntu.com:80/ --recv 22C4850146603F3DB0ED00479DA4BD18B9A06DE3  gpg: requesting key B9A06DE3 from hkp server keyserver.ubuntu.com  gpg: key B9A06DE3: "Launchpad PPA for Inkscape Developers" not changed  gpg: Total number processed: 1  gpg:              unchanged: 1  

What do I need to change so that the pc accepts the ppa?


Solution:1

Based on comments made by the OP on other answers (see this), we see a PPA 404 stating the PPAs 404 on Debian Wheezy checks to try and find Debian packages.

That suggests the original poster is using Debian, not Ubuntu.

PPAs from Launchpad will only support Ubuntu, and there is no Debian support currently. Don't try and mix Launchpad / Ubuntu PPAs and Debian.

You will need a Debian solution (check Debian Unstable for packages possibly) or you will have to build from source.


Solution:2

As @ThomasW. said

we see a PPA 404 stating the PPAs 404 on Debian Wheezy checks to try and find Debian packages.

Debian Wheezy is off-topic here.

Therefore the following solutions only works with Ubuntu systems



There is no problem. The PPA is added and the public key is imported.

Update the package information

sudo apt-get update  

Install inkscape with

sudo apt-get install inkscape  

Or upgrade your system if inkscape is already installed

sudo apt-get upgrade  

Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »