Ubuntu: I am running Ubuntu 14.04, python 2.7.8, I try to install python-setuptools, but it is giving following message



Question:

I am try to install python-setuptools but getting following messages: You might want to run 'apt-get -f install' to correct these: The following packages have unmet dependencies:

$ sudo apt-get install python-setuptools  Reading package lists... Done  Building dependency tree         Reading state information... Done  python-setuptools is already the newest version.  python-setuptools set to manually installed.    You might want to run 'apt-get -f install' to correct these:  The following packages have unmet dependencies:   icedtea-7-jre-jamvm : Depends: openjdk-7-jre-headless (= 7u65-2.5.2-3~14.04) but 7u65-2.5.1-4ubuntu1~0.14.04.2 is to be installed   openjdk-7-jre : Depends: openjdk-7-jre-headless (= 7u65-2.5.2-3~14.04) but 7u65-2.5.1-4ubuntu1~0.14.04.2 is to be installed  E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).  $ sudo easy-install virtualenv  sudo: easy-install: command not found  

I also try to update (sudo apt-get update) but it is giving the same message.


Solution:1

Read this lines carefully

icedtea-7-jre-jamvm : Depends: openjdk-7-jre-headless (= 7u65-2.5.2-3~14.04) but 7u65-2.5.1-4ubuntu1~0.14.04.2 is to be installed  openjdk-7-jre : Depends: openjdk-7-jre-headless (= 7u65-2.5.2-3~14.04) but 7u65-2.5.1-4ubuntu1~0.14.04.2 is to be installed  

All you need is reinstall openjdk package, because one of your packages depend on lower version of it.


Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »