Ubuntu: How to install Neovim on Ubuntu?



Question:

How can I install Neovim on Ubuntu? Should I compile it from source?

The installation steps are a little bit blurry for me...


Solution:1

From source

  1. Download the master branch from Github

  2. Install the dependencies

    sudo apt-get install libtool autoconf automake cmake libncurses5-dev g++  
  3. Go to the root of the project and build

    make cmake  make test  
  4. Run nvim in /neovim-master/build/bin

That works for me.

From the repository

  1. Add the repository

    $ sudo add-apt-repository ppa:neovim-ppa/unstable  
  2. Update and install

    $ sudo apt-get update  $ sudo apt-get install neovim  


Solution:2

According to official Wiki:

Neovim has been added to a Personal Package Archive which allows you to install it using apt-get on Ubuntu 12.04 and later

Run the following commands:

sudo add-apt-repository ppa:neovim-ppa/unstable  sudo apt-get update  sudo apt-get install neovim  

Prerequisites for the Python modules:

sudo apt-get install python-dev python-pip python3-dev python3-pip  


Solution:3

I've created a longer and hopefully more user friendly guide to installing neovim on Ubuntu. Hope this will be of use + provides an additional (albeit late) answer to your question: http://robinlovelace.net/computing/2014/04/19/installing-neovim-on-ubuntu.html


Solution:4

I followed the; git clone **; cd neovim; make cmake make test

ended up with nvim that worked, but isn't integrated with the system. I might leave him a few weeks/months to get it into some sort of state. But it does work.


Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »