Ubuntu: How to fix problems with following packages



Question:

I tried to install AmberTool. But when I followed the installation manual system told me to install the following dependencies:

sudo apt-get install csh flex gfortran g++ xorg-dev \       zlib1g-dev libbz2-dev patch python-tk python-matplotlib  

That gave me the following errors:

The following packages have unmet dependencies:     gfortran : Depends: gfortran-4.6 (>= 4.6.3-1~) but it is not going to be installed   libbz2-dev : Depends: libbz2-1.0 (= 1.0.6-1) but 1.0.6-4 is to be installed   xorg-dev : Depends: libfontenc-dev but it is not going to be installed                Depends: libfs-dev but it is not going to be installed              Depends: libice-dev but it is not going to be installed              Depends: libsm-dev but it is not going to be installed              Depends: libxaw7-dev but it is not going to be installed              Depends: libxcomposite-dev but it is not going to be installed              Depends: libxcursor-dev but it is not going to be installed              Depends: libxfont-dev but it is not going to be installed              Depends: libxft-dev but it is not going to be installed              Depends: libxinerama-dev but it is not going to be installed              Depends: libxmu-dev but it is not going to be installed              Depends: libxmuu-dev but it is not going to be installed              Depends: libxpm-dev but it is not going to be installed              Depends: libxrandr-dev              Depends: libxrender-dev but it is not going to be installed              Depends: libxres-dev but it is not going to be installed              Depends: libxss-dev but it is not going to be installed              Depends: libxt-dev but it is not going to be installed              Depends: libxtst-dev but it is not going to be installed              Depends: libxv-dev but it is not going to be installed              Depends: libxvmc-dev but it is not going to be installed              Depends: libxxf86dga-dev but it is not going to be installed  E: Unable to correct problems, you have held broken packages.  

I did run sudo apt-get update before running this but it did not change anything.

How can I fix those packages and install these dependencies?


Solution:1

Some of those packages exist in the universe repository. Not having that installed would cause the install to fail for obvious reasons. You can either enable this through the Update Manager settings or simply by:

sudo add-apt-repository universe  

Then sudo apt-get update again and go back to installing.


Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »