Ubuntu: hdmi not showing up in xrandr



Question:

Everything used to work until recently. Now, whenever I connect my HDMI monitor to my laptop nothing happens. Running xrandr doesn't show the HDMI output. Can anyone help out? I've been trying to fix this for the last 3 hours. I even reinstalled unity but that didn't work.

I'm on 14.04 ubuntu.

Any help is appreciated!!

Vladimir

> xrandr   Screen 0: minimum 320 x 200, current 1360 x 768, maximum 32767 x 32767  eDP1 connected primary 1360x768+0+0 (normal left inverted right x axis y axis)  344mm x 193mm       1920x1080      60.1 +   59.9     40.0           1680x1050      60.0     59.9            1600x1024      60.2            1400x1050      60.0            1280x1024      60.0            1440x900       59.9            1280x960       60.0            1360x768       59.8*    60.0            1152x864       60.0            1024x768       60.0            800x600        60.3     56.2            640x480        59.9     VGA1 disconnected (normal left inverted right x axis y axis)  VIRTUAL1 disconnected (normal left inverted right x axis y axis)  

Graphics card:

00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)


Solution:1

Ok, after a sleepless night of googling and trying things out (like reinstalling unity and the x drivers), I decided to try out Intel's approach. Apparently they officially support linux and they have a graphics driver installer (link below). After downloading and installing everything started working again.

I'm in Ubuntu heaven again.

Enjoy!

https://01.org/linuxgraphics/downloads/2014/intelr-graphics-installer-linux-1.0.7


Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »