Ubuntu: Failed to access Windows 8.1 NTFS partition from Ubuntu 13.10, even after disable fast startup



Question:

I am using Ubuntu 13.04, 32 bit and Windows 8.1. When I try to mount Windows 8.1 NTFS Partition it is showing this error message as below. Previously I was using Windows 7, but I have no problem to mount that partition. I tried to follow this answer and do as follows with Windows 8.1

Solution: Windows 8

There is a new feature in Windows 8 called Fast Startup. If this feature is enabled (which it is by default), Windows 8 does not actually completely shutdown when you choose "shutdown". Instead, it does a "hybrid shutdown". This is something like hibernating; it makes booting Windows 8 back up faster. So, you need to disable this feature to be able to shut it down properly, and be able to mount the Windows partitions. To do this, boot into your Windows 8 and:

Note: disabling Fast Startup will most likely make your Windows 8 take a longer time to boot. There are no "exact" numbers, but let's say that if it took you 10 seconds to boot into Windows 8, it will now take you 50 seconds after disabling this feature.  
  1. Open Control Panel in the small icons view and click on Power Options.
  2. Click on Choose what the power buttons do.
  3. Click on Change settings that are currently unavailable.
  4. Uncheck Turn on fast startup (recommended).

Click on Save changes. Now, shutdown Windows 8 and boot back into Ubuntu. You'll be able to mount without getting errors.

But I can not mount Windows 8.1 partition even after I done this. Can anyone help me, please! The error message is

  Error mounting /dev/sda2 at /media/rashed/Windows 8.1: Command-line `mount -t "ntfs" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000,dmask=0077,fmask=0177" "/dev/sda2" "/media/rashed/Windows 8.1"' exited with non-zero exit status 14: Windows is hibernated, refused to mount.      Failed to mount '/dev/sda2': Operation not permitted      The NTFS partition is in an unsafe state. Please resume and shutdown      Windows fully (no hibernation or fast restarting), or mount the volume      read-only with the 'ro' mount option.  


Solution:1

I solved this problem by running powercfg /h off in windows command terminal. This command usually disable windows hibernate permanently. I follow this instruction and now I have full access of windows partition.


Solution:2

The procedure of disabling the fast startup will stop win from storing metadata on all of the accessible hard-disks, but it doesn't get deleted right-away.

You need to run

ntfsfix /dev/sdXY  

where X is the volume letter e.g. b, if it's the secondary hard-disk and Y is the partition number e.g. 2 if it's the second partition.

That should make you able to mount it just fine.


Solution:3

If you're able to boot to the Windows login screen, you should be able to get around this by clicking the power menu in the lower right, holding down the Shift key, and clicking Shut Down. Just hold down shift until the machine fully powers off.

This should force a "full shutdown" from Windows, without requiring any login password. You should then be able to mount the Windows volume from your Linux instance without any errors.


Solution:4

have you tryed to install ntfs-3g to access the ntfs partition. also I think since windows still did a fast Startup i would try to do a reboot on windows to windows and try again ... and i think that a cache clean up might fix it.


Solution:5

By changing the permission in Windows 8 you can fix this problem. I have faced same problem as you faced. It is solved after providing the full access to the all user. I do not have any idea to the other consequences in Windows by doing this.


Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »