Ubuntu: Errors related to installing RSeQC



Question:

I have Python 2.7.6 installed but when running a python script (RSeQC scripts) with command:

$ python script.py   

I got errors:

ImportError: No module named qcmodule  

or

ImportError: No module named bx.bitset.  

What prerequisites do I need to install?


Solution:1

I believe you may need:

First,

sudo pip2 install qc bitsets RSeQC  

Next,

sudo pip2 install --upgrade cython bx-python pysam RSeQC numpy  

Alternatively,

Reinstall RSeQC:

sudo apt-get install libpython2.7-dev  wget 'http://downloads.sourceforge.net/project/rseqc/RSeQC-2.6.4.tar.gz'  tar zxvf RSeQC-2.6.4.tar.gz  RSeQC-2.6.4  python ./setup.py build  sudo python ./setup.py install  

This should build the needed modules. If the error persists, set an environment variable for the correct paths to the modules.


Solution:2

Try those commands:

sudo pip install -U qcmodule  sudo pip install -U bx.bitset  

Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »