Ubuntu: Error while installing vlc player



Question:

I am trying to install the VLC on my Ubuntu 14.04 system, while installing I got an error like below, please help me.

$ sudo apt-get install vlc    Reading package lists... Done  Building dependency tree         Reading state information... Done  Some packages could not be installed. This may mean that you have  requested an impossible situation or if you are using the unstable  distribution that some required packages have not yet been created  or been moved out of Incoming.  The following information may help to resolve the situation:    The following packages have unmet dependencies:   vlc : Depends: vlc-nox (= 2.1.6-0ubuntu14.04.1) but it is not going to be installed         Recommends: vlc-plugin-notify (= 2.1.6-0ubuntu14.04.1) but it is not going to be installed         Recommends: vlc-plugin-pulse (= 2.1.6-0ubuntu14.04.1) but it is not going to be installed  E: Unable to correct problems, you have held broken packages.  


Solution:1

try these steps :

  sudo apt-get update sudo apt-get upgrade  

then install synaptic:

  sudo apt-get install synaptic  

Use aptitude instead of apt-get:

  sudo aptitude install vlc  

if you don't have aptitude on your machine yet, get it with:

  sudo apt-get install aptitude  


Solution:2

Another method of troubleshooting may be to use aptitude rather than apt-get to try to install your package:

Use aptitude instead of apt-get:

sudo aptitude install vlc  


Solution:3

Installation of VLC using Synaptic Package Manager :

enter image description here

Select vlc and click on “Mark for Installation” and then click on Apply.


Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »