Ubuntu: Distribution not supported error when trying to install Intel Graphics Installer on Ubuntu 14.04



Question:

My processor is Intel core i3 inside x64 bit and RAM is 4 gb. When I used Windows 7 Intel was successfully installing, but now I am using Ubuntu 14.04 and Intel Installer makes me crazy!!! I've tried to change lsb-release, but is doesn't help me. I tried to reinstall signature and Intel Installer, but everything is the same!

I heard this problem was on Ubuntu 14.10, but not on Ubuntu 14.04.1 LTS. If someone knows why I have this error please help me...

enter image description here


Solution:1

Most versions of the Linux operating system include Intel graphics drivers. Intel recommends checking with your Linux distribution vendor or computer manufacturer for precompiled driver packages.Intel

The Intel Graphics Installer for Linux allows you to easily install the latest graphics and video drivers for your Intel graphics hardware. This allows you to stay current with the latest enhancements, optimizations, and fixes to the Intel® Graphics Stack to ensure the best user experience with your Intel graphics hardware. The Intel Graphics Installer for Linux is available for the latest versions of Ubuntu.

NOTE (updated 18 March 2015 09:15 UTC-7): This release of the Graphics Installer requires Ubuntu 14.10 "utopic". The Graphics Installer will not function on Ubuntu 14.04 "trusty" and support is deprecated (see this forum announcement and this explanation).The Intel Graphics Installer for Linux

You can try using the older driver, but I have no way of verifying that it will work. Depending on your needs, download the 32bit or 64bit or you can download the file from source: for 32bit or 64bit and then follow the commands below:

wget --no-check-certificate https://download.01.org/gfx/RPM-GPG-KEY-ilg -O - | sudo apt-key add -  sudo apt-get update  For 32 bit:  sudo dpkg -i intel-linux-graphics-installer_1.0.7-0intel1_i386.deb  OR for 64 bit:  sudo dpkg -i intel-linux-graphics-installer_1.0.7-0intel1_amd64.deb  

And then just start the installer

sudo intel-linux-graphics-installer  

I would recommend you install the file(s) using Gdebi. To install:

sudo apt-get install gdebi  


Solution:2

Because the installer could not work with 14.04.2 (HWE) or if a 14.04.1 user of the installer tried to install the lts-utopic mesa stack they've dropped any further support for 14.04.x

Read here for announcement - https://01.org/linuxgraphics/node/471

Personally don't think the Intel installer provided anything of real value, at least here with Haswell (mobile)

Updates for libva & vaapi are available from several ppa's, search if interested there.


Solution:3

How did i install intel linux graphics driver and it works for me:

For Ubuntu 14.04 with kernel linux-image-3.16.0-30:

1. Install kernel If not yet installed:

$ sudo apt-get linux-image-3.16.0-30-generic linux-image-extra-3.16.0-30-generic linux-headers-3.16.0-30-generic

2. Remove old kernels, e.g.:

$ sudo apt-get purge linux-image-3.13.0-24-generic linux-image-extra-3.13.0-24-generic linux-headers-3.13.0-24 linux-headers-3.13.0-24-generic

3. Add intel linux graphics repo:

$ sudo sh -c 'echo "deb https://download.01.org/gfx/ubuntu/14.04/main trusty main #intel-linux-graphics-installer" > /etc/apt/sources.list.d/intellinuxgraphics.list'
$ wget --no-check-certificate https://download.01.org/gfx/RPM-GPG-KEY-ilg -O - | sudo apt-key add -
$ sudo apt-get update

4. Install driver:

$ sudo apt-get install --reinstall i915-3.16-3.13-dkms xserver-xorg-video-intel i965-va-driver intel-gpu-tools

Next step might be unnecessary if backlight change works for you:

5. Add kernel param: acpi_osi=Linux instead of: acpi_osi=Linux acpi_backlight=vendor to linux line in /boot/grub/grub.cfg via grub-customizer.

Next step might be unnecessary if backlight change works for you:

6. Create file /etc/X11/xorg.conf.d/20-intel.conf with content:

Section "Device" Identifier "card0" Driver "Intel" Option "Backlight" "intel_backlight" BusID "PCI:0:2:0" EndSection

7. Update initramfs:

$ sudo update-initramfs -u -k all

And it works after reboot.


Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »