Ubuntu: cmake fail while configuring a project



Question:

i have a project to compile ,this is the file readme of this project,

Geodesic Object Proposals  =========================    Dependencies  ------------  Required:   * cmake   * c++11 compiler( g++-4.7 or higher, vc++2013 or higher, clang might work too )   * Eigen 3.2 (optionally you can download eigen and put in in external/eigen such that external/eigen/Eigen is a valid directory)   * libpng and libjpg (needed by cimg)    Optional for python3 bindings:   * python3 (python 2.7 should work too, but I didn't test it extensively)   * numpy   * boost-python   * matio (optional to load datasets)   * matplotlib for some visualizations   * MATLAB (r2013a on Ubuntu 14.04 tested, others might work too. You might have to specify a new gcc version in mexopts)  

Acctually i use the ubuntu wich has a default version of cmake 2.8.12.2 when i tried to configure my project i chosed as a current generator unix makefiles ,should i downoald one of the c++11 compiler mentioned in the readme? i have several errors

CMAKE_BACKWARDS_COMPATIBILITY 2.4  CMAKE_BUILD_TYPE  CMAKE_COLOR_MAKEFILE  CMAKE_CXX_COMPILER-NOTFOUND  CMAKE_CXX_FLAGS  CMAKE_CXX_FLAGS_DEBUG  CMAKE_CXX_FLAGS_MINIZEREL  CMAKE_CXX_FLAGS_RELEASE  CMAKE_CXX_FLAGS_RELWITHDEBINFO  CMAKE_C_COMPILER   /usr/bin/cc  CMAKE_C_FLAGS  CMAKE_C_FLAGS_DEBUG  CMAKE_C_FLAGS_MINIZEREL  CMAKE_C_FLAGS_RELEASE  CMAKE_C_FLAGS_RELWITHDEBINFO  CMAKE_INSTALL_PREFIX   /usr/local  CMAKE_LINKER    /usr/bin/ld  CMAKE_MAKE_PROGRAM   /usr/bin/make  

And many others thanks


Solution:1

Run the command below:

sudo apt-get install build-essential  

The most recent version of g++ for Trusty is 4.8.2

Ubuntu Package Search

Installing with the command below:

sudo apt-get install g++  

Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »