Ubuntu: Cant install UpWork Team app on Ubuntu 15.04



Question:

I tried to install the UpWork Team app on Ubuntu 15.04 (64-bit) but have problem with dependencies.

This deb package ask me to install: gksu, libgcrypt11 (>= 1.4.5) and libgnutls26 (>= 2.12.14-0)

I found libgcrypt11 (64/32) and installed it. But I can't find libgnutls26 which I also need to be installed for gksu.

Where can I download it, or which repository I need to add?


Solution:1

What happens if you try first:
sudo apt-get install libgcrypt11 libgnutls26 gksu
because these packages are available in the repositories so they should be installed automatically.


Solution:2

Problem resolved using a mirror package:

For x86_64/amd64 (64bit)

$ sudo wget https://mirror.umd.edu/ubuntu/pool/main/libg/libgcrypt11/libgcrypt11_1.5.3-2ubuntu4_amd64.deb    $ sudo dpkg -i libgcrypt11_1.5.3-2ubuntu4_amd64.deb  

Download a package here: "Debian-based 64-bit (Standard)"

$ sudo apt-get install gdebi-core    $ sudo gdebi upwork_amd64.deb  

For i386 (32bit)

$ sudo wget https://mirror.umd.edu/ubuntu/pool/main/libg/libgcrypt11/libgcrypt11_1.5.3-2ubuntu4_i386.deb    $ dpkg -i libgcrypt11_1.5.3-2ubuntu4_i386.deb  

Download a package here: "Debian-based 32-bit (Standard)"

$ sudo apt-get install gdebi-core    $ sudo gdebi upwork_i386.deb  


Solution:3

For Ubuntu 14.04 32-bit follow these two steps:

  1. Download old version of nss libraries.

    sudo wget http://security.ubuntu.com/ubuntu/pool/main/n/nss/libnss3_3.19.2-1ubuntu1_i386.deb  sudo wget http://security.ubuntu.com/ubuntu/pool/main/n/nss/libnss3-1d_3.19.2-1ubuntu1_i386.deb  
  2. Install downloaded packages.

    sudo dpkg -i libnss3*  

Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »