Ubuntu: Cannot run PHP after upgrading from apache 2.2 to apache 2.4



Question:

Im trying to upgrade Apache from 2.2.22 to Apache 2.4.x on Ubuntu 12.04. I have PHP5.3.10 running on my server for the application. When i install the new version of Apache 2.4 it uninstall the apache2-common and libapache2-mod-php5 and unable to run my applications.

I have tried to upgrade PHP to 5.4 and tried to upgrade apache. Followed few links, but didn't solve my issue.

https://launchpad.net/~ondrej/+archive/apache2?field.series_filter=precise apt-add-repository ppa:ptn107/apache

How to install the PHP library modules (libapache2-mod-php5) for apache2.4.

Thanks, Sivaprakash R


Solution:1

You need to use different PPA if you want apache 2.4 and PHP. There's ppa:ondrej/php5 that contains latest apache 2.4 and PHP 5.5.

PHP 5.4 and earlier is not supported with apache 2.4.


Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »