Ubuntu: apt-get update says I have not permission [duplicate]



Question:

This question already has an answer here:

lately whenever i try to update through the terminal I get this message

E: could not open lock file /var/lib/apt/lists/lock  - open (13: permission denied)  E: unable to lock directory /var/lib/apt/lists/  E: could not open lock file /var/lib/dpkg/lock  - open (13: permission denied)  E: unable to lock administration directory (/var/lib/dpkg/), are you root?  

I am using ubuntu 14.04.1 and apt-get had been working just fine until now


Solution:1

To run such command you need special permission.

Use sudo, but be carefull. It may ask for a password, that is the root password.


Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »