Ubuntu: why won't youtube videos play but all other websites work fine?



Question:

I've tried everything I can think of, asking in a forum in spanish, uninstalling flash, looking for 64 bit versions, sorry but my mind just does not have another idea here and I'm absolutely and totally frustrated.

Problem is that if I go to youtube.com and click on a video to watch, it won't play. The player will load, meaning that I can see the black square with the play button and everything, but, a few seconds later, it just says "there has been an error, try again later" and every single time I try, the exact same problem occurs. To make things even odder, if I go to whatever video website it'll work just fine, so you name it (vimeo, metacafe, etc.) they all work except youtube.

As I said I am extremely frustrated because I've tried everything I can think of, and nothing has had good results here.


Solution:1

I believe you are (or not are) in the HTML5 Video Player trial. Visit this link http://www.youtube.com/html5 if you are inside the trial just opt-out, if you are out, you may like to opt-in while flash is broken.

I would recommend you to check http://www.adobe.com/software/flash/about/ and see what version of flash you have installed. You may also purge the plugin and upgrade Firefox.

sudo apt-get purge flashplugin-installer  sudo apt-get upgrade  

Or try an alternative like Gnash:

sudo apt-get install gnash  


Solution:2

You can try to Re-install the Ubuntu Restricted Extras package, based on this answer to this question: YouTube Videos Stopped Streaming and Why do I have problems seeing YouTube??


Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »