Ubuntu: Ubuntu-GNOME 13.04 - Lock screen takes lot of time to unlock [closed]



Question:

I have gnome-screensaver package installed for using Ctrl+Alt+L to lock the screen. Though locking the screen works fine, it takes a whole lot of time to unlock after entering my password at the prompt. The lock screen just freezes during the time (mouse is active).

Here are the log messages from $HOME/.cache/gdm/session.log

  1. When screen is locked:

    (gnome-shell:2850): GLib-GIO-WARNING **: Dropping signal ActiveSessionChanged of type (s) since the type from the expected interface is (o)   (above message repeated 5 times)      JS ERROR: !!!   Exception was: TypeError: arguments[0] is null    JS ERROR: !!!     message = '"arguments[0] is null"'    JS ERROR: !!!     fileName = '"/usr/share/gnome-shell/js/ui/components/autorunManager.js"'    JS ERROR: !!!     lineNumber = '133'    JS ERROR: !!!     stack = '"(null,[object _private_Gio_IOErrorEnum])@/usr/share/gnome-shell/js/ui/components/autorunManager.js:133    ([object _private_Gio_DBusProxy],[object _private_Gio_SimpleAsyncResult])@/usr/share/gjs-1.0/overrides/Gio.js:86"'  
  2. When screen is unlocked:

    (gnome-shell:2850): GLib-GIO-WARNING **: Dropping signal ActiveSessionChanged of type (s) since the type from the expected interface is (o)  (above message repeated 4 times)    JS LOG: loading default theme (Adwaita)    (gnome-shell:2850): GLib-GIO-WARNING **: Dropping signal ActiveSessionChanged of type (s) since the type from the expected interface is (o)  (above message repeated 13 times)    JS ERROR: !!!   Exception was: TypeError: arguments[0] is null  JS ERROR: !!!     message = '"arguments[0] is null"'  JS ERROR: !!!     fileName = '"/usr/share/gnome-shell/js/ui/components/autorunManager.js"'  JS ERROR: !!!     lineNumber = '133'  JS ERROR: !!!     stack = '"(null,[object _private_Gio_IOErrorEnum])@/usr/share/gnome-shell/js/ui/components/autorunManager.js:133  ([object _private_Gio_DBusProxy],[object _private_Gio_SimpleAsyncResult])@/usr/share/gjs-1.0/overrides/Gio.js:86"'   (above block repeated 4 times)  

Are these related to the long delay/freeze in unlocking the screen? or is it caused by some other software etc.

Glad to provide any extra information in this regard. Thanks.


Solution:1

@DavidFoerster: Yes it is a bug.

See here: Launchpad Bug #515155. You may also find a workaround there.


Solution:2

Install the Tweak Tool if not already installed and the Gnome Shell extensions. The extensions are enabled in the Tweak Tool / Advanced Settings. The alternative status menu extension displays the shutdown menu. You can adjust it there.


Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »