Ubuntu: Ubuntu 13.04 not detect the HDMI sound output



Question:

So, I have maded the upgrade to ubuntu v.13.04, but, when I have maded this, my HDMI sound otuput sttoped to work... and, the HDMI sound device not appers any more on sound preferences :(

When I run lspci:

    00:00.0 Host bridge: Intel Corporation 3rd Gen Core processor DRAM Controller (rev 09)      00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)      00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)      00:16.0 Communication controller: Intel Corporation 7 Series/C210 Series Chipset Family MEI Controller #1 (rev 04)      00:1a.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)      00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)      00:1c.0 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 1 (rev c4)      00:1c.1 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 2 (rev c4)      00:1d.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)      00:1f.0 ISA bridge: Intel Corporation HM77 Express Chipset LPC Controller (rev 04)      00:1f.2 SATA controller: Intel Corporation 7 Series Chipset Family 6-port SATA Controller [AHCI mode] (rev 04)      00:1f.3 SMBus: Intel Corporation 7 Series/C210 Series Chipset Family SMBus Controller (rev 04)      01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 05)      02:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)  

That is the output... so, How I can detect my HDMI sound output, and use my HDMI oudio ??


Solution:1

I was facing the same problem. The following link helped me resolve it: http://ubuntuforums.org/showthread.php?t=2139459&page=3&p=12621337#post12621337

In short:

Go to the ALSA Launchpad and download the package: oem-audio-hda-daily-dkms* for your distribution. Then install it and reboot.


Solution:2

I don't have your hardware to verify (I can tell you it works fine on the previous hardware generation) this but I know my NVidia HDMI audio is broken on 13.04, the same fix may work for you this issues should be fixed in the next kernel update, in the meantime the mainline kernel (either 3.9rc8 or 3.8.8) should fix it Manual way:
http://kernel.ubuntu.com/~kernel-ppa/mainline/
You will want the all.deb and either every amd64.deb or i386.deb depending on weather you are using 32 or 64bit
Easy way:
How do I add the mainline kernel PPA?

If neither the 3.9rc8 or 3.8.8 kernels fix it for you, please mark this as not helpful

The 3.9.0 kernel should be out in a few days


Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »