Ubuntu: Problem with installing Some Packages and Updating my Ubuntu



Question:

I am somewhat new to this operating system. I have been using it since 6 months. Initially there was no problem with my operating system but since the day I messed up with some wine software whenever I Click on "Check" in the update software section after a while a window is popping up and it says "Failed to download repository information" When I click on details it is something like this:

W:Failed to fetch http://archive.ubuntu.com/ubuntu/dists/precise/Release  Unable to find expected entry 'commercial/binary-amd64/Packages' in Release file (Wrong sources.list entry or malformed file)  , W:Failed to fetch http://security.ubuntu.com/ubuntu/dists/precise-security/Release  Unable to find expected entry 'commercial/binary-amd64/Packages' in Release file (Wrong sources.list entry or malformed file)  , W:Failed to fetch http ://archive.ubuntu.com/ubuntu/dists/precise-updates/Release  Unable to find expected entry 'commercial/binary-amd64/Packages' in Release file (Wrong sources.list entry or malformed file)    , E:Some index files failed to download. They have been ignored, or old ones used instead.  

I am unable to figure out the actual problem since a couple of days. I am even unable to install some Software like VLC,SKYPE,TeamViewer even Wine also. I am being reported the same problem always it is something like this:

Package dependencies cannot be resolved    This error could be caused by required additional software packages which are missing or not installable. Furthermore there could be a conflict between software packages which are not allowed to be installed at the same time.      The following packages have unmet dependencies:    vlc: Depends: vlc-nox (= 2.0.3+git20120729+r318-0~r40~precise1) but 2.0.3+git20120729+r318-0~r40~precise1 is to be installed       Depends: libavcodec-extra-53 (>= 4:0.8-1~) but 4:0.8.3ubuntu0.12.04.1 is to be installed       Depends: libavutil-extra-51 (>= 4:0.8-1~) but 4:0.8.3ubuntu0.12.04.1 is to be installed       Depends: libc6 (>= 2.15) but 2.15-0ubuntu10 is to be installed       Depends: libfreetype6 (>= 2.2.1) but 2.4.8-1ubuntu2 is to be installed       Depends: libgcc1 (>= 1:4.1.1) but 1:4.6.3-1ubuntu5 is to be installed       Depends: libqtcore4 (>= 4:4.8.0) but 4:4.8.1-0ubuntu4.2 is to be installed       Depends: libqtgui4 (>= 4:4.7.0~beta1) but 4:4.8.1-0ubuntu4.2 is to be installed       Depends: libstdc++6 (>= 4.6) but 4.6.3-1ubuntu5 is to be installed       Depends: zlib1g (>= 1:1.2.3.3.dfsg) but 1:1.2.3.4.dfsg-3ubuntu4 is to be installed  

I became so ardent user of Ubuntu that It's impossible for me to uninstall and install it again. Can someone help me out here.?


Solution:1

Just press Ctrl+Alt+T on your keyboard to open Terminal. When it opens, run the commands below.

sudo apt-get install -f  sudo apt-get update  


Solution:2

Edited /etc/apt/sources.list manually and removed all instances of word "commercial". Problem solved. Backup that file first!


Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »