Ubuntu: POV Ray installation - configure error



Question:

I am trying to install POV-Ray 3.7 stable version. I downloaded the source code from github repo.

I followed the instruction for unix system which is described in the README file.

Unfortunately I get error message when I run configure command.

./configure COMPILED_BY="your name <email@address>"   

The first error said that it could not find the boost library 1.37 or higher, so I installed the libraries.

sudo apt-get install libboost-all-dev  

Now I can locate them as below:

/usr/lib/x86_64-linux-gnu/libboost_date_time.so.1.53.0  /usr/lib/x86_64-linux-gnu/libboost_iostreams.so.1.53.0  /usr/lib/x86_64-linux-gnu/libboost_program_options.so.1.53.0  /usr/lib/x86_64-linux-gnu/libboost_python-py27.so.1.53.0  /usr/lib/x86_64-linux-gnu/libboost_python-py33.so.1.53.0  /usr/lib/x86_64-linux-gnu/libboost_system.so.1.53.0  /usr/lib/x86_64-linux-gnu/libboost_thread.so.1.53.0  

And I tried to run the configure again, and the error message is like this.

...  checking for boostlib >= 1.37... yes  checking whether the Boost::Thread library is available... yes  checking for exit in -lboost_thread... yes  checking whether the boost thread library is usable... no  configure: error: in `/usr/local/povray-3.7-stable':  configure: error: cannot link with the boost thread library  See `config.log' for more details  

So I put additional option --with-boost-libdir=/usr/lib/x86_64-linux-gnu/, but it wasn't successful either.

Can anyone tell me what I am missing?


Solution:1

I found it.

The configure script was not able to find library links properly. I am writing this, in case there's anyone who has the same problem as mine.

./configure COMPILED_BY="name <email>" LIBS="-lboost_system -lboost_thread"  

This solved my problem, and here's some other solutions. [POV-Ray Newsgroup


Solution:2

Checking whether the boost thread library is usable... no  

You install might want to install libboost-thread1.53.0 too.


Solution:3

In Ubuntu 16.10, while Jiho Noh's answer will allow the configure script to run, the gcc compiler defaults to C++14 mode, which results in errors during the compilation. The configure line in Ubuntu 16.10 needs to be as follows:

./configure COMPILED_BY="name <email>" LIBS="-lboost_system -lboost_thread" CXXFLAGS="-std=c++98"  

This worked for me to build POV-Ray 3.7 from source.


Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »