Ubuntu: package system broken [duplicate]



Question:

This question already has an answer here:

While attempting updates in 12.04, I'm getting the following error:

The following packages have unmet dependencies:

linux-generic: Depends: linux-image-generic (= 3.2.0.44.53) but 3.2.0.45.54 is installed                 Depends: linux-headers-generic (= 3.2.0.44.53) but 3.2.0.45.54 is installed  

I've read other queries here, and tried various suggested solutions, such as disabling third party repositories, looking for broken packages in Synaptic, trying sudo apt-get clean and sudo apt-get -f install etc., without success.


Solution:1

Sometimes it happens that you try to update your own system while the Ubuntu archive itself is being updated. Such problems fix by themselves after a few hours or a day.


Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »