Ubuntu: How do I output audio through HDMI?



Question:

having a bit of an issue with getting audio to go through HDMI. Here are the base specs:

OS: Ubuntu Desktop 12.04.1 x64 CPU: AMD A10-5800K 3.8G 4M FM2 R Mobo: MSI FM2-A75MA-E35 OS: Ubuntu 12.04.1 LTS Vid Card: (integrated on CPU) AMD Radeon HD 7660D

HDMI sound works fine under Win7 (after mobo and vid drivers are installed), so it's not physically broken. Audio through the normal headphone jacks works fine under Ubuntu.

Looking at the audio panel, there is no HDMI output at all. aplay -l also reports only:

card 0: Generic [HD-Audio Generic], device 0: ALC887-VD Analog [ALC887-VD Analog]    Subdevices: 1/1    Subdevice #0: subdevice #0  

In additional drivers there are two versions:

ATI/AMD PROPRIETARY FGLRX GRAPHICS DRIVER  ATI/AMD PROPRIETARY FGLRX GRAPHICS DRIVER (post-release update)  

The first installs, but problem persists. I do get more resolutions to pick from. Second version does not, reporting it failed installation and to find details at: /var/log/jockey.log

Looked at the log, and it's insanely long, if necessary I can get it to you guys.

Did more research and some had luck by manually installing the drivers, so tried to give that a shot by following this:

https://help.ubuntu.com/community/BinaryDriverHowto/ATI#Manually_installing_Catalyst_12.6

starting at 3.1 Manually installing Catalyst 12.6. I immediately had 2 issues, (1) the AMD website does not provide any drivers for Linux, and (2) the following command did not work:

sudo sh amd-driver-installer-12-6-x86.x86_64.run --buildpkg Ubuntu/precise    sh: 0: Can't open amd-driver-installer-12-6-x86.x86_64.run  

Some other posts stated to update "alsa-drivers", but that also did not work as install command for the new version of them did not work. I forget the exact issue, but similar to above, cannot open / cannot find.

Any help would be greatly appreciated!


Solution:1

up vote 0 down vote

Does not work on. you don't help people like this!

Ubuntu disable and hide digital audio output SPDIF in all Realtek / Nvidia Cards by default in fact it does same in all flavor of Ubuntu because no body cares the final user.

The prosedure to fixit is the same in all verssion of ubuntu and works for all sound cards Ati Nvidia Realtek Creative Bosse etc. You need to edit a file to do work get a terminal and tipe this

sintax: sudo nano /etc/modprobe.d/alsa-base.conf (enter)

then add this line to the end of the file

sintax: options snd-hda-intel model=auto (then use the end page controls to rewrite and save the file, then exit console)

At this time you need to reboot the machine, and then realize the missing digital audio spdif its work! go to task bar icon to select propper devise (its show now) to avoid get sound for all speackers at same time. if you need mute ubuntu alets or whatever you need to do enjoy.

for spanish take this link: http://www.fermu.com/es/articulos/linux/48-ubuntu/773-configurar-audio-hdmi-a-trav%C3%A9s-de-una-tarjeta-gr%C3%A1fica-nvidia-geforce-8600m-gt-en-ubuntu

Boggart Akerley NASA Space Ship Program Sofware Engineer.


Solution:2

A guy on ubuntuforums.org was able to point me in the right way: install Pulse Audio Volume Control.

My particular solution was this:

go to the daily ALSA buids:

https://code.launchpad.net/~ubuntu-audio-dev/+archive/alsa-daily/+packages

download my version: ~precise1

get the .deb file with _all.deb ending.

In the terminal, go to the folder where you d/l the .deb file, and running the following command:

sudo dpkg -i package.deb  

Restart your machine, once back in, go to the audio control panel, and set it to HDMI.

Note: my comp ~froze~ (non-responsive windows, but mouse was ok) for about 10-20 seconds, then un-froze and worked fine.


Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »