Ubuntu: Error: When I try to install any package



Question:

I am using Ubuntu 12.10. I am in great trouble when I tried to install firefox browser. However firefox installation is broken on my system. After this when I go to UBUNTU SOFTWARE CENTER it showing me this message every time and fail to install any other package.

UBUNTU SOFTWARE CENTER :

Item cannot be installed or removed until the package catalog is repaired.

When I try to install anything from terminal I always get this below message:

Error1 :

The following packages have unmet dependencies: firefox-globalmenu : Depends: firefox (= 19.0~b5+build1-0ubuntu0.12.04.1~mfn1)

Please tell how I can repair it. Looking for your guidance.

==========================================================================

        yes I just seen it and tried this  command: apt-get -f install  

E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied) E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?

            PLEASE SEE FROM HERE WHAT MESSAGE I HAVE :              deepak@deepak-laptop:/$ sudo apt-get -f install              Reading package lists... Done              Building dependency tree                      Reading state information... Done               Correcting dependencies... Done              The following extra packages will be installed:               firefox firefox-globalmenu               Suggested packages:               latex-xft-fonts firefox-gnome-support             The following NEW packages will be installed:              firefox             The following packages will be upgraded:             firefox-globa lmenu            1 upgraded, 1 newly installed, 0 to remove and 220 not upgraded.             1 not fully installed or removed.            Need to get 0 B/24.8 MB of archives.           After this operation, 51.0 MB of additional disk space will be used.           Do you want to continue [Y/n]? y           (Reading database ... 354341 files and directories currently installed.)           Unpacking firefox (from  .../firefox_19.0~b6+build1-0ubuntu0.12.04.1~mfn1_i386.deb) ...               dpkg: error processing /var/cache/apt/archives /firefox_19.0~b6+build1-0ubuntu0.12.04.1~mfn1_i386.deb (--unpack):               trying to overwrite '/usr/lib/firefox/plugins', which is also in package acroread 9.5.1-1precise1              No apport report written because MaxReports is reached already                                                            Processing triggers for man-db ...                      Processing triggers for desktop-file-utils ...                     Processing triggers for bamfdaemon ...                   Rebuilding /usr/share/applications/bamf.index...              Processing triggers for gnome-menus ...              Errors were encountered while processing:                   /var/cache/apt/archives  /firefox_19.0~b6+build1-0ubuntu0.12.04.1~mfn1_i386.deb                  E: Sub-process /usr/bin/dpkg returned an error code (1)  

==========================================================================

Thanks


Solution:1

Try running sudo apt-get install -f in the terminal. This attempts to correct a system with broken dependencies in place.


Solution:2

You need to run uninstall acroread 9.5.1-1precise1 from your system.That is probably creating problems.

Simply try uninstalling acroread using sudo apt-get remove acroread After that, try installing firefox again. In my opinion it should go through after that.


Solution:3

Force dpkg to overwrite files:

sudo dpkg --force-overwrite -i /var/cache/apt/archives/firefox_19.0~b6+build1-0ubuntu0.12.04.1~mfn1_i386.deb  

Then, run this command to fix remaining unconfigured packages:

sudo apt-get -f install  

Anyways, as someone else stated, the culprit here is probably the acroread package. If you continue to see these messages, just uninstall acroread from your system.


Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »