Ubuntu: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.



Question:

I got this error while installing ubuntu-restricted-extras:

E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.

So I ran that in terminal:

vennesa@vennesa-ThinkPad-R61:~$ sudo dpkg --configure -a  Setting up update-notifier-common (0.126) ...  flashplugin-installer: downloading http://archive.canonical.com/pool/partner/a/adobe-flashplugin/adobe-flashplugin_11.2.202.270.orig.tar.gz  

Since then I can't install any thing. What do I do?


Solution:1

Upon returning to installing Gnome via sudo apt-get install ubuntu-desktop, that was cut off by a power outage and I experienced exactly this issue.

I chose to issue the sudo dpkg --configure -a and then lost my terminal window forever in Windows Hyper-V 2012 manager. I was able to connect to my Linux box using SSH (PuTTY) from my Windows 7 Pro client though no problem.


Solution:2

If I understand correctly, you believe the terminal is freezing/not working once that flasplugin-installer: line appears.

However, Adobe Flash is a proprietary program with a license that doesn't allow direct distributing by Ubuntu. Because of this, flash updates using the flashplugin-installer, which downloads and installs the latest version of flash onto your computer.

So, when you see this line, and it doesn't appear to be doing anything, the terminal is actually downloading the latest version of flash flash. Wait a while, and it should continue.


Solution:3

I find out an easy way, if sudo dpkg --configure -a wasting so much of time in installing your file just give abort the process and give sudo dpkg --remove -a it will remove all the uninstalled files and if you want you can install it again by giving sudo apt-get install your_soft_name.


Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »