Ubuntu: /dev/sda2 contains a filesystem with error after partitioning (updated)



Question:

I just wanted to create a separate home partition on my Ubuntu 12.10 system. I booted the liveDVD, resized the sda2 partition (28gb of data resized to 30gb based on MiB [originally on a 100gb partition]) and made a new ext4 partition for the home folder. The drive is an SSD drive. I had changed the settings (noatime etc.) for SSD succesfully a week ago. On reboot I get the following error:

/dev/sda2 contains a filesystem with errors  Inode 74669 has an invalid extent node (blk 6881289)  fsd / [953] terminated with status 4  

I was following this HOWTO, but I did not get to changing any of the files or configs other than those with gparted.

I have a (two-week old) SSD Samsung drive which is functioning just fine. Other specs: 64bit 12.10, i7, 8gb ram, nvidia.

UPDATE: When trying to recover the data in my encrypted home folder before a clean install I ran dmesg. The following things I do not understand, do you?

  • fb: conflicting fb hw usage inteldrmfb vs EFI VGA - removing generic driver
  • ACPI Warning: 0x0000000000000460 - 0x000000000000047f SystemIO conflicts with region VPMIO (20120320/utaddress-251)
  • ACPI ... rather than the native driver
  • lpc_ich Resource conflict(s) found affecting iTCO_wdt

This message I get for about a 100 inodes:

Valid ecryptfs headers not found in file header region or xattr region, inode 99738

Is it a problem that I resized a partition which contains an encrypted folder?

FINAL UPDATE:

The system was corrupt. It had to do with ecryptfs. See: eCryptfs: Input/output error. I reinstalled.


Solution:1

So you increased the size of sda2? A filesystem can live in a partition bigger than its size, but if you want take advantage of this additional size, you have to resize your filesystem. Gparted should have done this for you automatically. Usually this isn't a risky process... Did the Gparted operation went through without errors?

The mentioned block 6881289 is inside your partition size (at 26.25GiB) so this block should be just fine...

I would suggest to check your partition table again, did you move your sda2 partition? Is the partition than before? Try using fdisk and the command (p)print.

Then you should do a full fsck on that drive (run on the unmounted filesystem from a LiveCD). Scan for bad blocks using the -c option (-f for force, means even the fs is marked as clean and -v for verbose). If more errors appear, there is probably a hardware failure.

fsck -cvf /dev/sda2  

Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »