Ubuntu: Authentication required to Mount a Device



Question:

Today I came across a very strange message when today i double click the drive WHICH HAS NTFS FORMAT it give me this message THAT AUTHENTICATION IS REQUIRED TO MOUNT A DEVICE I know with root user password u can do this but I have not set the root user password and I don't know the default one.

So can any one tell me how to solve this issue. Graphically and through command Line.

enter image description here

And same thing happen when i tried to install a theme , terminal slapped me with this message " umairmustafa is not in the sudoers file. This incident will be reported."

What on earth is going on.


Solution:1

It sounds like you may have removed yourself from the "sudo" group - did you edit your user group memberships recently? In order to use sudo, you need to be a member of this group, or specifically added to the sudoers file. However, if you remove this group membership, only someone with root authority can add it back or make a change. You won't be able to install anything new, either.

Note that prior to 12.04, Ubuntu used the "admin" group instead of the "sudo" group, where Debian used the "sudo" group. So, if you upgraded to 12.04, it's possible that you may have been a member of the admin group rather than sudo. Either or both will work, but I'd imagine that "sudo" should now be the preferred group for administrative users.

To confirm if this is your problem, try entering "groups" at a commandline in the terminal. If you don't see either "admin" or "sudo" (one or both), then this is your problem. If you do see one of them, then you may need to directly edit your /etc/sudoers file (as root, of course).

But don't despair, there is a way to get around this, although it's not as simple as most people would like. You will need to gain root access, which can be done at startup with a little work.

First, you need to log in to a single user console mode: here is a good how-to for that. It tells how to fix a variety of causes for the problem you are having (apparently). It's slightly dated, and uses "admin" group instead of "sudo", so substitute accordingly.


Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »