Ubuntu: 12.04 ALSA error



Question:

My system crashes regularly due to probably the alsa driver. The system suddenly becomes unusable slow, although the music keeps playing. I tried to submit it to the ALSA team, but I can't get in their bug submitting system ... This is on a HP 8530w with a Intel 82801I (ICH9 Family) HD Audio

        Feb 18 21:54:11 laptop pulseaudio[1980]: [alsa-sink] alsa-util.c: snd_pcm_avail() returned a value that is exceptionally large: 404124 bytes (2290 ms).  Feb 18 21:54:11 laptop pulseaudio[1980]: [alsa-sink] alsa-util.c: Most likely this is a bug in the ALSA driver 'snd_hda_intel'. Please report this issue to the ALSA developers.  Feb 18 21:54:11 laptop pulseaudio[1980]: [alsa-sink] alsa-util.c: snd_pcm_dump():  Feb 18 21:54:11 laptop pulseaudio[1980]: [alsa-sink] alsa-util.c: Hardware PCM card 0 'HDA Intel' device 0 subdevice 0  Feb 18 21:54:11 laptop pulseaudio[1980]: [alsa-sink] alsa-util.c: Its setup is:  Feb 18 21:54:11 laptop pulseaudio[1980]: [alsa-sink] alsa-util.c:   stream       : PLAYBACK  Feb 18 21:54:11 laptop pulseaudio[1980]: [alsa-sink] alsa-util.c:   access       : MMAP_INTERLEAVED  Feb 18 21:54:11 laptop pulseaudio[1980]: [alsa-sink] alsa-util.c:   format       : S16_LE  Feb 18 21:54:11 laptop pulseaudio[1980]: [alsa-sink] alsa-util.c:   subformat    : STD  Feb 18 21:54:11 laptop pulseaudio[1980]: [alsa-sink] alsa-util.c:   channels     : 2  Feb 18 21:54:11 laptop pulseaudio[1980]: [alsa-sink] alsa-util.c:   rate         : 44100  Feb 18 21:54:11 laptop pulseaudio[1980]: [alsa-sink] alsa-util.c:   exact rate   : 44100 (44100/1)  Feb 18 21:54:11 laptop pulseaudio[1980]: [alsa-sink] alsa-util.c:   msbits       : 16  Feb 18 21:54:11 laptop pulseaudio[1980]: [alsa-sink] alsa-util.c:   buffer_size  : 16384  Feb 18 21:54:11 laptop pulseaudio[1980]: [alsa-sink] alsa-util.c:   period_size  : 8192  Feb 18 21:54:11 laptop pulseaudio[1980]: [alsa-sink] alsa-util.c:   period_time  : 185759  Feb 18 21:54:11 laptop pulseaudio[1980]: [alsa-sink] alsa-util.c:   tstamp_mode  : ENABLE  Feb 18 21:54:11 laptop pulseaudio[1980]: [alsa-sink] alsa-util.c:   period_step  : 1  Feb 18 21:54:11 laptop pulseaudio[1980]: [alsa-sink] alsa-util.c:   avail_min    : 13034  Feb 18 21:54:11 laptop pulseaudio[1980]: [alsa-sink] alsa-util.c:   period_event : 0  Feb 18 21:54:11 laptop pulseaudio[1980]: [alsa-sink] alsa-util.c:   start_threshold  : -1  Feb 18 21:54:11 laptop pulseaudio[1980]: [alsa-sink] alsa-util.c:   stop_threshold   : 1073741824  Feb 18 21:54:11 laptop pulseaudio[1980]: [alsa-sink] alsa-util.c:   silence_threshold: 0  Feb 18 21:54:11 laptop pulseaudio[1980]: [alsa-sink] alsa-util.c:   silence_size : 0  Feb 18 21:54:11 laptop pulseaudio[1980]: [alsa-sink] alsa-util.c:   boundary     : 1073741824  Feb 18 21:54:11 laptop pulseaudio[1980]: [alsa-sink] alsa-util.c:   appl_ptr     : 113727673  Feb 18 21:54:11 laptop pulseaudio[1980]: [alsa-sink] alsa-util.c:   hw_ptr       : 113812320  


Solution:1

This is a guess based on this post

in terminal, run:

gksudo gedit /etc/pulse/client.conf  

change line nr. 27

from

;autospawn = yes  

to

;autospawn = no  

save, close, see if it helps

if not, revert the client.conf file to its original state and report back


Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »