Ubuntu: Unable to install Wine on Ubuntu 16.10 due to i386 packages



Question:

I am attempting to install wine on Ubuntu 16.10 and it will not install properly due to issues with the 32 bit packages.

Using the Wine PPA, it cascades down to

wine-staging-i386:i386 : Depends: libgphoto2-6:i386 (>= 2.5.10) but it is not going to be installed  

.... and so on.

Using the standard Ubuntu PPA, it fails when installing wine32:

wine32:i386 : Depends: libwine:i386 (= 1.8.5-1ubuntu1) but it is not going to be installed  

And attempts to install those packages create errors about their dependencies, and so on down the line. I have added the i386 architecture:

sudo dpkg --add-architecture i386  

And attempted to use aptitude to force the issue, which didn't help. Also, at least in the case of libwine, the amd64 version installed matches the i386 versioning exactly:

Depends: libwine:i386 (= 1.8.5-1ubuntu1) but it is not going to be installed  libwine is already the newest version (1.8.5-1ubuntu1)  

I did have an old repository (xenial) installed at one point, but installed no packages from it (I ended up installing the package I needed - libpng12 - manually; installing the i386 version alongside did not fix anything)

Additionally: I have no held packages and no pending updates.


Solution:1

Ubuntu 16.10 offers wine-stable (1.8.5) and wine-development (1.9.20) -- why did you use a wine ppa? Either should install directly with a

sudo apt-get install wine-stable     (or wine-development)    

Use ppa-purge (install if necessary) to get rid of the inconsistent packages you have installed

sudo ppa-purge <whatever wine ppa you used>  

and try one of the standard installs.


Since Wine is community supported, you have to enable the universe software source. Run Software Updater, click on the "Settings" buttton, and under the Ubuntu Software tab, click on the "Community maintained free and open source..." checkbox. (first box, Canonical-supported should also have been checked).


The version of libwine:386 on my fresh wine install is 1.8.5-1ubuntu2 not ...ubuntu1

   ii  libwine:i386   1.8.5-1ubuntu2   i386   Windows API implementation - library    

I'd suggest you uninstall every wine package you can identify with

dpkg -l | grep wine  

and reinstall wine-stable

sudo apt-get install wine-stable  

Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »