Ubuntu: Trouble installing AMDGPU-PRO Ubuntu 16.04.2



Question:

Hey here are some infos first: Ubuntu 16.04.2 Fresh Install Kernel 4.8.0-41 AMD R9 285

I'm trying to install the AMDGPU-Pro driver without success. I tried 16.40, 16.50 and 16.60 none of them is working properly. After installing and restarting the system I'm getting no signal on my monitor, the system is running tho.

While running the install script im getting the following error:

Setting up dkms (2.2.0.3-2ubuntu11.3) ...      Setting up amdgpu-pro-dkms (16.40-348864) ...      Loading new amdgpu-pro-16.40-348864 DKMS files...      First Installation: checking all kernels...      Building only for 4.8.0-41-generic      Building for architecture x86_64      Building initial module for 4.8.0-41-generic      Error! Bad return status for module build on kernel: 4.8.0-41-generic (x86_64)      Consult /var/lib/dkms/amdgpu-pro/16.40-348864/build/make.log for more information.  

This is the make.log:

DKMS make.log for amdgpu-pro-16.40-348864 for kernel 4.8.0-41-generic (x86_64)  Do 16. Mär 16:03:27 CET 2017  make: Entering directory '/usr/src/linux-headers-4.8.0-41-generic'    LD      /var/lib/dkms/amdgpu-pro/16.40-348864/build/built-in.o    LD      /var/lib/dkms/amdgpu-pro/16.40-348864/build/amd/amdgpu/built-in.o    CC [M]  /var/lib/dkms/amdgpu-pro/16.40-348864/build/amd/amdgpu/amdgpu_drv.o  In file included from /var/lib/dkms/amdgpu-pro/16.40-348864/build/amd/amdgpu/../backport/backport.h:9:0,                   from <command-line>:0:  /var/lib/dkms/amdgpu-pro/16.40-348864/build/amd/amdgpu/../backport/include/kcl/kcl_ttm.h: In function ‘kcl_ttm_bo_reserve’:  /var/lib/dkms/amdgpu-pro/16.40-348864/build/amd/amdgpu/../backport/include/kcl/kcl_ttm.h:109:9: error: too many arguments to function ‘ttm_bo_reserve’    return ttm_bo_reserve(bo, interruptible, no_wait, false, ticket);           ^  In file included from /var/lib/dkms/amdgpu-pro/16.40-348864/build/amd/amdgpu/../backport/include/kcl/kcl_ttm.h:6:0,                   from /var/lib/dkms/amdgpu-pro/16.40-348864/build/amd/amdgpu/../backport/backport.h:9,                   from <command-line>:0:  ./include/drm/ttm/ttm_bo_driver.h:863:19: note: declared here   static inline int ttm_bo_reserve(struct ttm_buffer_object *bo,                     ^  scripts/Makefile.build:289: recipe for target '/var/lib/dkms/amdgpu-pro/16.40-348864/build/amd/amdgpu/amdgpu_drv.o' failed  make[2]: *** [/var/lib/dkms/amdgpu-pro/16.40-348864/build/amd/amdgpu/amdgpu_drv.o] Error 1  scripts/Makefile.build:440: recipe for target '/var/lib/dkms/amdgpu-pro/16.40-348864/build/amd/amdgpu' failed  make[1]: *** [/var/lib/dkms/amdgpu-pro/16.40-348864/build/amd/amdgpu] Error 2  Makefile:1491: recipe for target '_module_/var/lib/dkms/amdgpu-pro/16.40-348864/build' failed  make: *** [_module_/var/lib/dkms/amdgpu-pro/16.40-348864/build] Error 2  make: Leaving directory '/usr/src/linux-headers-4.8.0-41-generic'  

Does someone know how to fix it?


Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »